Marilyn Monroooooe.

Or, “Why I wanna replace the Carlson LongHaul radios”.

I’m basing the name of this post off incorrectly remembering this glorious scene from the Pop Team Epic anime and thinking it said long strokes, not  longs for good strokes, but whatever – I’m keeping it:

Ever just work with a piece of load-bearing hardware that is just asking for the sweet release of the e-waste bin? Yeah, that’s what half the entries on this page are about, but here’s one that, uh, yeah. The Carlson Wireless LongHaul… It’s still on their website as if it were a current product but upon calling their support engineer for assistance he told me what I had already come to suspect, it was abandonware from over a decade ago. The unit is a long range microwave radio designed to carry telephone traffic and look like a TDM (T1?) link, but also IP traffic, which is what we’re using it for.

So let’s check off the Boxes Of Decay:

  • Flash user interface
  • User interface via https with REVOKED SECURITY CERTIFICATE
  • Best I can tell— based on 802.11A wifi hardware
  • Cursed
  • Did I mention cursed

The only way to keep these things in service is to have an old version of Flash that hasn’t been expired via logic bomb – Ruffle won’t cut it as it doesn’t support Actionscript 3, though it handles http://aktiv-schaum.kg4cyx.net/ just fine. I’m sure you all missed those goofy Flash shitposts, right? I sure did. It also seems to play my old Fanimutations just fine.
If you have the Ruffle extension loaded:
Aligator (unfinished!)

Guava Paste

Onsokumaru’s Great Adventure

I wish to state here that there are some dumb jokes in there that were very much a bad product of the time and I feel like they don’t age well, but not that I’d want to bury this entirely.

Anyway— on to the weird old hardware.

The board says “Avlia Networking Platform” on it and it looks like maybe an older version of this guy

The wifi card slotted into it is a Wistron-Neweb dual band radio, interestingly.. this unit only supports the 5.8 ghz side but some of the other ones we have in service, inexplicably, support both 2.4 and 5.8, consult your pineal gland

The serial and USB connections are unpopulated and I found no other way into the device…

Well, you can telnet in, but the user/password are unknown. It says it runs FreeBSD.

Finally by some sheer luck I found I had one old system with Flash on it and was able to set these creaky old things up. In the user interface (I can’t be arsed to take a screenshot) it has signal level readings which… uh, it’ll say it’s seeing -38dBm when the radio it’s connected to is unplugged and disconnected, and everything takes like four tries to get it to save and take effect and the Reboot button doesn’t work and

I’m so tired. I’m just so tired. can I just have a couple of Ubiquiti bullets and a nap? Please? Thank you. GAAAAAAABORAAAAAAAAAAAAAA

Leave a Reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.